Project

General

Profile

Bug #480

"lbu st" does not work on encrypted apkovl's

Added by Mika Havela about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Base libraries
Target version:
Start date:
11/22/2010
Due date:
% Done:

100%

Estimated time:
Affected versions:
Security IDs:

Associated revisions

Revision 5458719d (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: fix lbu status to handle encrypted apkovl

ref #480

Revision 0bd949f2 (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: fix lbu status to handle encrypted apkovl - second try

previous only removed unused patch. This is the real thing

ref #480

Revision 7016b230 (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: upgrade to 2.5.4

ref #472
ref #480

Revision 47392952 (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: fix lbu status to handle encrypted apkovl

ref #480
(cherry picked from commit 5458719dce4fd32e742b85360aa5af33b2315868)

Revision 6f00b168 (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: fix lbu status to handle encrypted apkovl - second try

previous only removed unused patch. This is the real thing

ref #480
(cherry picked from commit 0bd949f2206eddafb94f3f63022851b9a355a4b4)

Revision 202d4fde (diff)
Added by Natanael Copa about 9 years ago

main/alpine-conf: upgrade to 2.5.4

fixes #472
fixes #480
(cherry picked from commit 7016b23025fc387306f35a04391fe2bcd8eebcc2)

History

#1 Updated by Mika Havela about 9 years ago

  • Category set to Base libraries
  • Target version set to Alpine 2.1.3

Sorry - I accidentally committed this bug report before it was finished.
---
Basically all 'lbu' functionallity is out of order when using encrypted apkovl's.
When running 'lbu st' you get prompted for encryption password (twice). But you only get "tar: invalid gzip magic" as result.
When booting up using the encrypted apkovl all seems ok. It's just the 'lbu' functionallity that seems to be out of order.

#2 Updated by Mika Havela about 9 years ago

Thans for the fix. I tested it.
The fix works fine for 'lbu st' but when using 'lbu diff' I get unreadable output.

#3 Updated by Mika Havela about 9 years ago

Update: I didn't notice that some of the information is readable (diff output).
The readable information passes early in the output followed by unreadable output (encrypted data).

#4 Updated by Natanael Copa about 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Natanael Copa
  • % Done changed from 0 to 80

could you please try alpine-conf-2.5.4 from edge?

If its ok I'll cherry-pick it for 2.1-stable

Thanks!

#5 Updated by Natanael Copa about 9 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 80 to 100

#6 Updated by Natanael Copa almost 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF